Quick Guide for Creating Accessible PDFs

Setting a Logical Reading Order
Document content is read in the order in which the content appears in the Tags tree. It is best to only manipulate the tags in the Tags pane. Check the reading order by:
1. Open the Tags pane
2. Activate the context menu (or right click) of any tag and ensure Highlight Content is selected.
   a. Note the selected tag’s content will be highlighted in the document area.
3. Use the arrow keys on the keyboard to navigate up and down and determine if the order of the content is in the visually implied order.

Applying Heading Structure
Headings identify sections of information. Headings also assist users navigate documents and understand the hierarchy of information. Headings should be ordered properly (using H1 followed by H2, through H6). Not every emphasized phrase (bold, italicized, etc.) should be structured as a heading.
1. Locate the container tag (P, Span, etc.) containing the text that should be structured as a heading in the Tags pane.
2. Activate the context menu (or right click) of the container tag and select Properties.
3. In the Object Properties dialog, on the Tag tab from the Type drop down select the appropriate Heading Level tag type.

Handling Repetitive or Decorative Content
Non-distinct header and footer content, decorative images, drawing remnants and others should be labeled as artifacts.
1. Locate the tag containing the decorative or repetitive content in the Tags pane. Select the tag containing the text to artifact, not the container (P, Figure, Span, etc.)
2. Activate the context menu (or right click) of the tag and select Change Tag to Artifact.
3. Navigate to and activate OK in the Create Artifact dialog.

Structuring Lists & Table of Contents (TOC)
It is important to structure lists properly to ensure proper relationships and hierarchy are provided. Bulleted or numbered lists should contain L, LI, Lbl, and LBody tags. The bullet or number text tag is placed as a child of the Lbl tag. The text of the item is placed as a child of the LBody tag.
Table of Contents need to have a TOC, TOCI, Reference, and Link structure for linked TOCs. The item description, leader, page number and Link-OBJR are placed as a child of the Link tag. Examples of proper list and TOC structure are provided.
To create a list or table of contents structure:
1. In the Tags pane, activate the context menu (or right click) near a tag where the new list or TOC should be placed.
3. In the New Tag dialog, from the Type drop down select List (L) or Table of Contents (TOC).
4. Activate the OK button.
5. Activate the context menu (or right click) of the newly created tag and select New Tag.
6. In the New Tag dialog, from the Type drop down select List Item (LI) or Table of Contents Item (TOCI).
7. If necessary, move the new LI or TOCI tag beneath the L or TOC (respectively) as a child tag.
8. Repeat the steps to access the New Tag dialog and select Label (Lbl) and List Item Body (LBody) to complete a List structure. Select Reference then Link to complete a TOC structure.
9. Move the structure tags and the text content tags as necessary to match a similar outline as the example images.

Constructing a Sub-List
Often times lists and table of contents contain nested, or sub-list, items. These items must be properly placed in the structure to provide users with the correct hierarchy information. Sub-lists must have a new parent L or TOC tag as a sibling to the text tag in which the sub-item relates. Examples of proper structure follow.
Quick Guide for Creating Accessible PDFs

Designing Tables

Tables must have a tag structure that includes Table, TR, TH, and TD tags. TH is a row or column header. TD represents the data cells. There are two types of data tables. In a simple data table a data cell has a 1-to-1 relationship with a row and/or column header. In a complex table data cells can be related to two or more row and/or column headers.

Example Simple Data Table:

<table>
<thead>
<tr>
<th>Header 1 Text</th>
<th>Header 2 Text</th>
<th>Header 3 Text</th>
</tr>
</thead>
<tbody>
<tr>
<td>Row Header</td>
<td>Column 2, row 2 data cell text</td>
<td>Column 3, row 2 data cell text</td>
</tr>
</tbody>
</table>

Example Tag Structure:

Complex tables need to have IDs on the headers. The data cells need to list associated headers. The Table Editor can assist in identifying headers and associating them. Access the Table Editor and add header associations by:

1. Navigate to the Accessibility pane and activate TouchUp Reading Order.
2. Over the table structure, activate the context menu (or right click) and select Table Editor.
3. Select a table header cell, activate the context menu (or right click) and select Table Cell Properties.
4. In the Table Cell Properties dialog enter a name in the ID field. Then navigate to and activate the OK button.

Creating Links

A link must have the structure of the Link tag with the text tag and a Link-OBJR tag nested as siblings beneath Link. If a link needs to be added navigate to the Edit PDF pane. Select Link > Add / Edit Web or Document Link tool, select the content to be linked and follow the Create Link wizard. Often content is clickable with a mouse but does not have the Link-OBJR structure in the tags. To tag unmarked links:

1. In the Tags pane, navigate to the text tag that is intended to be a link.
2. Activate the context menu (or right click) of the tag and select Find.
3. In the Find Element dialog, from the Find drop down select Unmarked Links.
4. Navigate to and activate the Find button.
5. Upon the desired content being highlighted, navigate to and activate the Tag Element button.
6. Navigate to and activate Close.
7. Confirm in the Tags pane that there is now a Link-OBJR tag as a sibling to the text tag of the link.

Use the steps provided in the Structuring Lists and Table of Contents section to create the structure for sub-lists. Arrange the tags as necessary to nest them properly and appear similar to the example images.

Creating Links

A link must have the structure of the Link tag with the text tag and a Link-OBJR tag nested as siblings beneath Link. If a link needs to be added navigate to the Edit PDF pane. Select Link > Add / Edit Web or Document Link tool, select the content to be linked and follow the Create Link wizard. Often content is clickable with a mouse but does not have the Link-OBJR structure in the tags. To tag unmarked links:

1. In the Tags pane, navigate to the text tag that is intended to be a link.
2. Activate the context menu (or right click) of the tag and select Find.
3. In the Find Element dialog, from the Find drop down select Unmarked Links.
4. Navigate to and activate the Find button.
5. Upon the desired content being highlighted, navigate to and activate the Tag Element button.
6. Navigate to and activate Close.
7. Confirm in the Tags pane that there is now a Link-OBJR tag as a sibling to the text tag of the link.
5. Repeat steps 4 & 5 for all Table Header cells.
6. For each data cell, select the cell and select **Table Cell Properties** from the context menu (or right click).
7. In the **Table Cell Properties** dialog select the **Add (+)** button for Associated Header Cell IDs.
8. Add the headers in a bottom to top order in which the headers need to be read.

**Providing Alternate Text**

Often times in Adobe Acrobat images, charts and graphs are presented as `<Figure>` tags. All meaningful images must provide a concise, meaningful description. A meaningful image is one that is important to understanding the surrounding content. Concise alternate text should not be more than 250 characters. Complex images (graphs, charts, schemas, etc.) need longer descriptions provided in surrounding text or in appendices. Alternate text can be added or edited through the **TouchUp Reading Order (TURO)** tool.

1. Open the **Accessibility** pane. Navigate to and select the **TouchUp Reading Order** tool.
2. In the main document, locate the image that needs alternate text or edits to the alternate text.
3. Activate the context menu (or right click) of the image and select **Edit Alternate Text** from the menu.
4. In the **Alternate Text** dialog, make the necessary changes or additions.
5. When finished, navigate to and activate the **OK** button.

**Addressing Color & Contrast**

Effective use of color will ensure that content is readable, accessible, and appealing.

1. Color should not be used as the only visual means of conveying information, indicating an action, prompting a response, or distinguishing a visual element.
   a. Example, graphs may need textured patterns to represent a data set (this must be done in the source application). Or important information should have textual representation before it such as an asterisk (*).
2. Verify text color provides enough contrast against the background color. There must be a minimum contrast ratio of **4.5:1**.
   a. Use **Edit PDF** to select the desired text.
   b. Then use the **Font Color** picker to choose an appropriate color against the background.

**Making Fillable Forms**

The structure of form fields is a `<Form>` tag with a nested **Field Name** – OBJR tag. In the **Tags** pane the form object tags for text fields need to appear after the tag containing the text label of the field. (Checkboxes and radio buttons should be positioned to the left of the labels, and thus before their text label in the tags.)

**Providing Tooltips for Form Fields**

Tooltips identify the purpose of the field to users. It is important that any constraint, formatting or group information is included in the tooltip. For example, if a field is required that information needs to be part of the tooltip. If a block of fields relate to a shipping address and another block relates to billing, it is important to indicate the category before the field name – ex. “Billing – City”. To add tooltips:

1. Navigate to the **Prepare Forms** pane.
2. When the form editing mode becomes active, activate the context menu (or right click) of the desired form field and select **Properties**.
3. In the **Properties** dialog, on the **General** tab write a meaningful, concise description in the **Tooltip** field.
4. Navigate to and activate the **Close** button.
Grouping Radio Buttons
In order for radio buttons to perform as a related group they must have the same group name but unique choice names. For example, there could be multiple questions with 'yes' and 'no' radio buttons. To set up radio buttons:
1. Navigate to the Prepare Forms pane.
2. When the form editing mode becomes active, activate the context menu (or right click) of the desired radio button and select Properties.
3. In the Properties dialog, on the General tab write the same meaningful, concise description in the Name and Tooltip fields. Example: Question 1 or Gender.
4. Navigate to and activate the Options tab.
5. In the Radio Button Choice field and enter the specific answer option for the radio button. Example: Yes or Male. Assistive technology announces the Tooltip + Radio Button Choice.
6. Navigate to and activate the Close button.

Using Document Properties
It is important that documents provide a meaningful title and set the appropriate language so that the document can be interpreted as intended.
1) Navigate to File > Properties.
   a) To set a descriptive title, ensure the Description tab is active.
      i) Locate the Title field and enter a phrase that describes the purpose of the document.
      ii) Navigate to and select the Initial View tab.
      iii) Locate the Window Options > Show drop down and select Document Title from the options.

   b) To set the primary language of the document, navigate to and select the Advanced tab.
      i) Under Reading Options select the primary language of the document from the Language drop down.
2) Navigate to and activate the OK button.

Validate Accessibility with Full Check
Running the Full Check accessibility checker can help identify some accessibility issues; however, the checker cannot detect all potential issues. It is necessary to additionally perform a manual inspection of the Tags structure. To run Full Check:
1. Navigate to and expand the Tools > Accessibility pane.
2. Locate and activate Full Check.
3. In the Accessibility Checker Options dialog review the settings and make any necessary adjustments. Tip: The default settings usually provide sufficient results.
4. When ready, navigate to and activate the Start Checking button.
5. After the checker runs, results will appear in the Accessibility Report pane on the left.
6. Review the results and make any necessary modifications. Most changes will need to be made through the Tags pane.
   a. Activate the context menu (or right click) of an issue to Explain, Check Again or Skip Rule.